summary refs log tree commit diff stats
path: root/user/modules/tabnine.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/modules/tabnine.nix')
-rw-r--r--user/modules/tabnine.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/user/modules/tabnine.nix b/user/modules/tabnine.nix
index b8ed3773..1c9b1a96 100644
--- a/user/modules/tabnine.nix
+++ b/user/modules/tabnine.nix
@@ -61,11 +61,9 @@ in
       text = cfg.registrationKey;
     };
 
-    programs.neovim.plugins = [
-      pkgs.vimPlugins.coc-tabnine
-    ];
-    programs.neovim.coc.settings = {
-      "tabnine.binary_path" = "${pkgs.tabnine}/bin/TabNine";
+    programs.nixvim.plugins = {
+      blink-compat.enable = true;
+      cmp-tabnine.enable = true;
     };
 
     programs.emacs.extraPackages = epkgs: [