summary refs log tree commit diff stats
path: root/user/modules/satoshipay.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/modules/satoshipay.nix')
-rw-r--r--user/modules/satoshipay.nix12
1 files changed, 8 insertions, 4 deletions
diff --git a/user/modules/satoshipay.nix b/user/modules/satoshipay.nix
index 5821103d..6516bd59 100644
--- a/user/modules/satoshipay.nix
+++ b/user/modules/satoshipay.nix
@@ -1,6 +1,7 @@
 { config, pkgs, ... }:
 
 let
+  inherit (pkgs) stdenv;
   spGitConfig = {
     user.email = "alan@satoshipay.io";
   };
@@ -13,11 +14,10 @@ in
   home.sessionVariables = {
     KUBECTX_IGNORE_FZF = "1";
   };
-  home.packages = with pkgs; [
+  home.packages = with pkgs; ([
     caddy
     openssl
     mongodb-tools
-    pgadmin
     pgcli
     s3cmd
     sops
@@ -27,12 +27,16 @@ in
     unstable.docker_compose
     unstable.kubernetes
     unstable.kubectx
-    unstable.redis-desktop-manager
     unstable.kubernetes-helm
     unstable.helmfile
+  ] ++ (lib.optionals (!stdenv.isDarwin)
+  [
+    pgadmin
+
+    unstable.redis-desktop-manager
     unstable.robo3t
     unstable.slack
-  ];
+  ]));
 
   programs.git.includes = [
     {