summary refs log tree commit diff stats
path: root/user/modules/satoshipay.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/modules/satoshipay.nix')
-rw-r--r--user/modules/satoshipay.nix55
1 files changed, 0 insertions, 55 deletions
diff --git a/user/modules/satoshipay.nix b/user/modules/satoshipay.nix
deleted file mode 100644
index 6516bd59..00000000
--- a/user/modules/satoshipay.nix
+++ /dev/null
@@ -1,55 +0,0 @@
-{ config, pkgs, ... }:
-
-let
-  inherit (pkgs) stdenv;
-  spGitConfig = {
-    user.email = "alan@satoshipay.io";
-  };
-in
-{
-  imports = [
-    ./javascript.nix
-  ];
-
-  home.sessionVariables = {
-    KUBECTX_IGNORE_FZF = "1";
-  };
-  home.packages = with pkgs; ([
-    caddy
-    openssl
-    mongodb-tools
-    pgcli
-    s3cmd
-    sops
-
-    unstable.mkcert
-    unstable.google-cloud-sdk
-    unstable.docker_compose
-    unstable.kubernetes
-    unstable.kubectx
-    unstable.kubernetes-helm
-    unstable.helmfile
-  ] ++ (lib.optionals (!stdenv.isDarwin)
-  [
-    pgadmin
-
-    unstable.redis-desktop-manager
-    unstable.robo3t
-    unstable.slack
-  ]));
-
-  programs.git.includes = [
-    {
-      condition = "gitdir:~/projects/github.com/satoshipay/";
-      contents = spGitConfig;
-    }
-    {
-      condition = "gitdir:~/projects/gitlab.satoshipay.tech";
-      contents = spGitConfig;
-    }
-  ];
-
-  home.file.".npmrc".text = ''
-    @satoshipay:registry=https://registry.npmjs.org/
-  '';
-}