summary refs log tree commit diff stats
path: root/user/modules/nvim-coc.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/modules/nvim-coc.nix')
-rw-r--r--user/modules/nvim-coc.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/user/modules/nvim-coc.nix b/user/modules/nvim-coc.nix
new file mode 100644
index 00000000..5aa462f0
--- /dev/null
+++ b/user/modules/nvim-coc.nix
@@ -0,0 +1,25 @@
+{ config,  lib, pkgs, ... }:
+
+with lib;
+
+let
+  inherit (pkgs) stdenv;
+  cfg = config.programs.neovim.coc;
+in
+{
+  options.programs.neovim.coc = {
+    config = mkOption {
+      type = types.attrs;
+      default = {};
+      description = ''
+        Settings for coc.nvim
+      '';
+    };
+  };
+
+  config = {
+    xdg.configFile."nvim/coc-settings.json" = {
+      source = pkgs.writeText "coc-settings.json" (builtins.toJSON cfg.config);
+    };
+  };
+}