summary refs log tree commit diff stats
path: root/user/modules/nixos.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/modules/nixos.nix')
-rw-r--r--user/modules/nixos.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/user/modules/nixos.nix b/user/modules/nixos.nix
index 0df5817b..64b523b8 100644
--- a/user/modules/nixos.nix
+++ b/user/modules/nixos.nix
@@ -11,4 +11,11 @@
       };
     })
   ];
+
+  programs.zsh.shellAliases = {
+    nor = "nixos-rebuild";
+    nors = "nixos-rebuild switch";
+    norb = "nixos-rebuild boot";
+    norr = "nixos-rebuild switch --rollback";
+  };
 }