summary refs log tree commit diff stats
path: root/user/lima.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/lima.nix')
-rw-r--r--user/lima.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/user/lima.nix b/user/lima.nix
index 67103ffe..1bcf2647 100644
--- a/user/lima.nix
+++ b/user/lima.nix
@@ -1,4 +1,4 @@
-{ pkgs, ... }:
+{ config, pkgs, ... }:
 {
   imports = [
     ./modules/tabnine.nix
@@ -12,8 +12,15 @@
   home = {
     username = "alan";
     homeDirectory = "/home/alan.linux";
+    sessionVariables = {
+      GHQ_ROOT = "/Users/alan/projects";
+      SSH_AUTH_SOCK = "/Users/alan/.strongbox/agent.sock";
+    };
     stateVersion = "22.11";
   };
+  programs.ssh.extraConfig = ''
+    IdentityAgent ${config.home.sessionVariables.SSH_AUTH_SOCK}
+  '';
   # home-manager complains when setting nix.conf otherwise
   nix.package = pkgs.nix;
   nix.settings = {