summary refs log tree commit diff stats
path: root/system/settings/user-interface.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/user-interface.nix')
-rw-r--r--system/settings/user-interface.nix17
1 files changed, 11 insertions, 6 deletions
diff --git a/system/settings/user-interface.nix b/system/settings/user-interface.nix
index 078f71cb..7fec2f88 100644
--- a/system/settings/user-interface.nix
+++ b/system/settings/user-interface.nix
@@ -1,9 +1,14 @@
-{ config, pkgs, lib, makeDesktopItem, ... }:
-
-{ documentation.info.enable = true;
+{
+  config,
+  pkgs,
+  lib,
+  makeDesktopItem,
+  ...
+}: {
+  documentation.info.enable = true;
   nixpkgs.config.firefox.enableOfficialBranding = true;
 
-  environment.pathsToLink = [ "/share/zsh" ];
+  environment.pathsToLink = ["/share/zsh"];
 
   environment.systemPackages = with pkgs; [
     aria2
@@ -31,7 +36,7 @@
   services.devmon.enable = true;
 
   systemd.user.services.trash-clean = {
-    path = with pkgs; [ trash-cli ];
+    path = with pkgs; [trash-cli];
     description = "Remove old files from FreeDesktop.org trash";
 
     serviceConfig = {
@@ -40,7 +45,7 @@
     script = "trash-empty 30";
   };
   systemd.user.timers.trash-clean = {
-    wantedBy = [ "default.target" ];
+    wantedBy = ["default.target"];
     timerConfig = {
       OnCalendar = "weekly";
       Persistent = true;