summary refs log tree commit diff stats
path: root/system/settings/user-interface.nix
diff options
context:
space:
mode:
authorAlan Pearce2022-10-16 23:49:18 +0200
committerAlan Pearce2022-10-16 23:56:07 +0200
commit05dd85210e465caa44ef7254f2781b2d12ba2882 (patch)
tree85ccc720e339dd5ca8d7eb3ce6a3488c78675235 /system/settings/user-interface.nix
parent472dbbdbb246cf3d8ce3a5c3c6cefaa07b7589df (diff)
downloadnixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.tar.lz
nixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.tar.zst
nixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.zip
Reformat files with alejandra
Diffstat (limited to 'system/settings/user-interface.nix')
-rw-r--r--system/settings/user-interface.nix17
1 files changed, 11 insertions, 6 deletions
diff --git a/system/settings/user-interface.nix b/system/settings/user-interface.nix
index 078f71cb..7fec2f88 100644
--- a/system/settings/user-interface.nix
+++ b/system/settings/user-interface.nix
@@ -1,9 +1,14 @@
-{ config, pkgs, lib, makeDesktopItem, ... }:
-
-{ documentation.info.enable = true;
+{
+  config,
+  pkgs,
+  lib,
+  makeDesktopItem,
+  ...
+}: {
+  documentation.info.enable = true;
   nixpkgs.config.firefox.enableOfficialBranding = true;
 
-  environment.pathsToLink = [ "/share/zsh" ];
+  environment.pathsToLink = ["/share/zsh"];
 
   environment.systemPackages = with pkgs; [
     aria2
@@ -31,7 +36,7 @@
   services.devmon.enable = true;
 
   systemd.user.services.trash-clean = {
-    path = with pkgs; [ trash-cli ];
+    path = with pkgs; [trash-cli];
     description = "Remove old files from FreeDesktop.org trash";
 
     serviceConfig = {
@@ -40,7 +45,7 @@
     script = "trash-empty 30";
   };
   systemd.user.timers.trash-clean = {
-    wantedBy = [ "default.target" ];
+    wantedBy = ["default.target"];
     timerConfig = {
       OnCalendar = "weekly";
       Persistent = true;