summary refs log tree commit diff stats
path: root/system/settings/services/zeroconf.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/services/zeroconf.nix')
-rw-r--r--system/settings/services/zeroconf.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/system/settings/services/zeroconf.nix b/system/settings/services/zeroconf.nix
new file mode 100644
index 00000000..0b428c54
--- /dev/null
+++ b/system/settings/services/zeroconf.nix
@@ -0,0 +1,16 @@
+{ config, pkgs, lib, ... }:
+
+{ services.avahi = {
+    enable = true;
+    nssmdns = true;
+    ipv6 = true;
+  };
+  systemd.services.avahi-daemon.wantedBy = lib.mkForce [];
+  systemd.timers.avahi-daemon = {
+    description = "Delayed startup of Avahi";
+    wantedBy = [ "timers.target" ];
+    timerConfig = {
+      OnActiveSec = "1 min";
+    };
+  };
+}