summary refs log tree commit diff stats
path: root/system/settings/services/samba.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/services/samba.nix')
-rw-r--r--system/settings/services/samba.nix16
1 files changed, 8 insertions, 8 deletions
diff --git a/system/settings/services/samba.nix b/system/settings/services/samba.nix
index 63283e88..729a6756 100644
--- a/system/settings/services/samba.nix
+++ b/system/settings/services/samba.nix
@@ -1,16 +1,16 @@
-{ config, pkgs, ... }:
-
-let
-  workgroup = "WORKGROUP";
-
-in
 {
+  config,
+  pkgs,
+  ...
+}: let
+  workgroup = "WORKGROUP";
+in {
   services.samba-wsdd = {
     inherit workgroup;
     enable = true;
   };
-  networking.firewall.allowedTCPPorts = [ 5357 ];
-  networking.firewall.allowedUDPPorts = [ 3702 ];
+  networking.firewall.allowedTCPPorts = [5357];
+  networking.firewall.allowedUDPPorts = [3702];
 
   services.samba = {
     enable = true;