summary refs log tree commit diff stats
path: root/system/settings/services/samba.nix
diff options
context:
space:
mode:
authorAlan Pearce2022-10-16 23:49:18 +0200
committerAlan Pearce2022-10-16 23:56:07 +0200
commit05dd85210e465caa44ef7254f2781b2d12ba2882 (patch)
tree85ccc720e339dd5ca8d7eb3ce6a3488c78675235 /system/settings/services/samba.nix
parent472dbbdbb246cf3d8ce3a5c3c6cefaa07b7589df (diff)
downloadnixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.tar.lz
nixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.tar.zst
nixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.zip
Reformat files with alejandra
Diffstat (limited to 'system/settings/services/samba.nix')
-rw-r--r--system/settings/services/samba.nix16
1 files changed, 8 insertions, 8 deletions
diff --git a/system/settings/services/samba.nix b/system/settings/services/samba.nix
index 63283e88..729a6756 100644
--- a/system/settings/services/samba.nix
+++ b/system/settings/services/samba.nix
@@ -1,16 +1,16 @@
-{ config, pkgs, ... }:
-
-let
-  workgroup = "WORKGROUP";
-
-in
 {
+  config,
+  pkgs,
+  ...
+}: let
+  workgroup = "WORKGROUP";
+in {
   services.samba-wsdd = {
     inherit workgroup;
     enable = true;
   };
-  networking.firewall.allowedTCPPorts = [ 5357 ];
-  networking.firewall.allowedUDPPorts = [ 3702 ];
+  networking.firewall.allowedTCPPorts = [5357];
+  networking.firewall.allowedUDPPorts = [3702];
 
   services.samba = {
     enable = true;