summary refs log tree commit diff stats
path: root/system/settings/programs/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/programs/shell.nix')
-rw-r--r--system/settings/programs/shell.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/system/settings/programs/shell.nix b/system/settings/programs/shell.nix
index c0e50690..62d51230 100644
--- a/system/settings/programs/shell.nix
+++ b/system/settings/programs/shell.nix
@@ -8,9 +8,12 @@
       promptInit = "";
     }
     // (
+      # Either of these will call `compinit`, causing >2s startup time
+      # Do it in home-manager instead
       if pkgs.stdenv.isDarwin
-      then { }
-      else {
+      then {
+        enableCompletion = false;
+      } else {
         enableGlobalCompInit = false;
       }
     );