summary refs log tree commit diff stats
path: root/system/settings/programs/base.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/programs/base.nix')
-rw-r--r--system/settings/programs/base.nix23
1 files changed, 4 insertions, 19 deletions
diff --git a/system/settings/programs/base.nix b/system/settings/programs/base.nix
index efde273d..47ed4c07 100644
--- a/system/settings/programs/base.nix
+++ b/system/settings/programs/base.nix
@@ -1,26 +1,11 @@
 { pkgs, ... }: {
   environment.systemPackages = with pkgs; [
-    nixpkgs-review
-    nix-output-monitor
-    cachix
     home-manager
+    brotli
     lzma
     lzop
     zstd
-  ];
-  nix.settings = {
-    substituters = [
-      "https://nix-community.cachix.org"
-      "https://deploy-rs.cachix.org"
-      "https://binarycache.alanpearce.eu"
-      "https://deploy-rs.cachix.org"
-    ];
-
-    trusted-public-keys = [
-      "deploy-rs.cachix.org-1:xfNobmiwF/vzvK1gpfediPwpdIP0rpDV2rYqx40zdSI="
-      "nix-community.cachix.org-1:mB9FSh9qf2dCimDSUo8Zy7bkq5CX+/rkCWyvRCYg3Fs="
-      "deploy-rs.cachix.org-1:xfNobmiwF/vzvK1gpfediPwpdIP0rpDV2rYqx40zdSI="
-      "binarycache.alanpearce.eu:ZwqO3XMuajPictjwih8OY2+RXnOKpjZEZFHJjGSxAI4="
-    ];
-  };
+  ] ++ (lib.optionals (stdenv.isLinux) [
+    psmisc
+  ]);
 }