summary refs log tree commit diff stats
path: root/system/settings/pin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/pin.nix')
-rw-r--r--system/settings/pin.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/system/settings/pin.nix b/system/settings/pin.nix
new file mode 100644
index 00000000..2ff2e773
--- /dev/null
+++ b/system/settings/pin.nix
@@ -0,0 +1,14 @@
+let
+  inherit (import ../../sources.nix) sources;
+in
+{
+  nix = {
+    nixPath = [
+      "nixpkgs=flake:nixpkgs"
+    ];
+    registry.nixpkgs.to = {
+      type = "path";
+      path = sources.nixpkgs;
+    };
+  };
+}