summary refs log tree commit diff stats
path: root/system/settings/pin.nix
diff options
context:
space:
mode:
authorAlan Pearce2025-03-02 15:18:43 +0100
committerAlan Pearce2025-03-02 23:56:41 +0100
commitb5bcdf72cbc998550bf55af1842fe65f8c9ef0bf (patch)
tree06d7f026a1d6a026aeb548cf7a920a437270d995 /system/settings/pin.nix
parent734a3cebed8dd4be66a546179dbda890abc5a10d (diff)
downloadnixfiles-b5bcdf72cbc998550bf55af1842fe65f8c9ef0bf.tar.lz
nixfiles-b5bcdf72cbc998550bf55af1842fe65f8c9ef0bf.tar.zst
nixfiles-b5bcdf72cbc998550bf55af1842fe65f8c9ef0bf.zip
Revert "Switch back to flakes"
This reverts commit c0384c43821474d28af1d9696ceb473a0d769292.
Diffstat (limited to 'system/settings/pin.nix')
-rw-r--r--system/settings/pin.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/system/settings/pin.nix b/system/settings/pin.nix
new file mode 100644
index 00000000..2ff2e773
--- /dev/null
+++ b/system/settings/pin.nix
@@ -0,0 +1,14 @@
+let
+  inherit (import ../../sources.nix) sources;
+in
+{
+  nix = {
+    nixPath = [
+      "nixpkgs=flake:nixpkgs"
+    ];
+    registry.nixpkgs.to = {
+      type = "path";
+      path = sources.nixpkgs;
+    };
+  };
+}