summary refs log tree commit diff stats
path: root/system/settings/pin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/pin.nix')
-rw-r--r--system/settings/pin.nix12
1 files changed, 8 insertions, 4 deletions
diff --git a/system/settings/pin.nix b/system/settings/pin.nix
index e282cf66..533149fe 100644
--- a/system/settings/pin.nix
+++ b/system/settings/pin.nix
@@ -1,8 +1,12 @@
-{ pkgs, ... }:
 let
-  lib = import ../../lib { inherit pkgs; };
-  sources = import ../../nix/sources.nix;
+  inherit (import ../../sources.nix) nixPath sources;
 in
 {
-  nix.nixPath = lib.mkNixPath sources;
+  nix = {
+    inherit nixPath;
+    registry.nixpkgs.to = {
+      type = "path";
+      path = sources.nixpkgs;
+    };
+  };
 }