summary refs log tree commit diff stats
path: root/system/settings/hardware/trezor.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/hardware/trezor.nix')
-rw-r--r--system/settings/hardware/trezor.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/system/settings/hardware/trezor.nix b/system/settings/hardware/trezor.nix
new file mode 100644
index 00000000..33cc6f25
--- /dev/null
+++ b/system/settings/hardware/trezor.nix
@@ -0,0 +1,13 @@
+{ config, lib, pkgs, ... }:
+
+{ services.trezord.enable = true;
+  environment.systemPackages = with pkgs; [
+    gnupg
+    pinentry
+    (python3.withPackages(ps: with ps; [ trezor_agent wheel ]))
+  ];
+  programs.gnupg.agent = {
+    enable = lib.mkForce false;
+    enableSSHSupport = lib.mkForce false;
+  };
+}