summary refs log tree commit diff stats
path: root/system/settings/hardware/trezor.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/hardware/trezor.nix')
-rw-r--r--system/settings/hardware/trezor.nix12
1 files changed, 8 insertions, 4 deletions
diff --git a/system/settings/hardware/trezor.nix b/system/settings/hardware/trezor.nix
index 60867e07..e24fc92e 100644
--- a/system/settings/hardware/trezor.nix
+++ b/system/settings/hardware/trezor.nix
@@ -1,10 +1,14 @@
-{ config, lib, pkgs, ... }:
-
-{ services.trezord.enable = true;
+{
+  config,
+  lib,
+  pkgs,
+  ...
+}: {
+  services.trezord.enable = true;
   environment.systemPackages = with pkgs; [
     gnupg
     pinentry
-    (python3.withPackages(ps: with ps; [ trezor_agent wheel ]))
+    (python3.withPackages (ps: with ps; [trezor_agent wheel]))
     trezor-suite
   ];
   programs.gnupg.agent = {