summary refs log tree commit diff stats
path: root/system/settings/hardware/mouse.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/hardware/mouse.nix')
-rw-r--r--system/settings/hardware/mouse.nix14
1 files changed, 5 insertions, 9 deletions
diff --git a/system/settings/hardware/mouse.nix b/system/settings/hardware/mouse.nix
index b30d4124..df57073e 100644
--- a/system/settings/hardware/mouse.nix
+++ b/system/settings/hardware/mouse.nix
@@ -1,12 +1,8 @@
 { config, pkgs, ... }:
 
-{ services.xserver.config = ''
-    Section "InputClass"
-        Identifier "Mouse (No Acceleration)"
-        MatchIsPointer "yes"
-        MatchIsTouchpad "no"
-        Option "AccelerationProfile" "-1"
-        Option "AccelerationScheme" "none"
-    EndSection
-  '';
+{ 
+  services.xserver.libinput = {
+    accelProfile = "flat";
+    accelSpeed = "0";
+  };
 }