summary refs log tree commit diff stats
path: root/system/settings/hardware/mouse.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/hardware/mouse.nix')
-rw-r--r--system/settings/hardware/mouse.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/system/settings/hardware/mouse.nix b/system/settings/hardware/mouse.nix
new file mode 100644
index 00000000..b30d4124
--- /dev/null
+++ b/system/settings/hardware/mouse.nix
@@ -0,0 +1,12 @@
+{ config, pkgs, ... }:
+
+{ services.xserver.config = ''
+    Section "InputClass"
+        Identifier "Mouse (No Acceleration)"
+        MatchIsPointer "yes"
+        MatchIsTouchpad "no"
+        Option "AccelerationProfile" "-1"
+        Option "AccelerationScheme" "none"
+    EndSection
+  '';
+}