summary refs log tree commit diff stats
path: root/system/settings/hardware/keyboard.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/hardware/keyboard.nix')
-rw-r--r--system/settings/hardware/keyboard.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/system/settings/hardware/keyboard.nix b/system/settings/hardware/keyboard.nix
index 20030760..c6241f8f 100644
--- a/system/settings/hardware/keyboard.nix
+++ b/system/settings/hardware/keyboard.nix
@@ -2,9 +2,9 @@
 , pkgs
 , ...
 }: {
-  services.xserver = {
+  services.xserver.xkb = {
     layout = "us,de";
-    xkbVariant = "intl-unicode,nodeadkeys";
-    xkbOptions = "altwin:prtsc_rwin,caps:escape_shifted_capslock";
+    variant = "intl-unicode,nodeadkeys";
+    options = "altwin:prtsc_rwin,caps:escape_shifted_capslock";
   };
 }