summary refs log tree commit diff stats
path: root/system/settings/hardware/grub2.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/hardware/grub2.nix')
-rw-r--r--system/settings/hardware/grub2.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/system/settings/hardware/grub2.nix b/system/settings/hardware/grub2.nix
index e0043692..cd1fd619 100644
--- a/system/settings/hardware/grub2.nix
+++ b/system/settings/hardware/grub2.nix
@@ -1,4 +1,4 @@
-{ config, pkgs, ... }:
+{ config, pkgs, lib, ... }:
 
 { boot.loader = {
     grub = {
@@ -7,7 +7,7 @@
       version = 2;
       device = "nodev";
       efiSupport = true;
-      useOSProber = true;
+      useOSProber = lib.mkDefault true;
     };
     efi.canTouchEfiVariables = true;
   };