summary refs log tree commit diff stats
path: root/system/settings/hardware/connman.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/hardware/connman.nix')
-rw-r--r--system/settings/hardware/connman.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/system/settings/hardware/connman.nix b/system/settings/hardware/connman.nix
new file mode 100644
index 00000000..0361f9cb
--- /dev/null
+++ b/system/settings/hardware/connman.nix
@@ -0,0 +1,14 @@
+{ config, pkgs, ... }:
+
+{ networking.connman = {
+    enable = true;
+    enableVPN = false;
+  };
+  networking.wireless.enable = true;
+
+  environment.systemPackages = with pkgs; [
+    cmst
+    connman-notify
+    connman_dmenu
+  ];
+}