summary refs log tree commit diff stats
path: root/system/settings/hardware/bluetooth.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/hardware/bluetooth.nix')
-rw-r--r--system/settings/hardware/bluetooth.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/system/settings/hardware/bluetooth.nix b/system/settings/hardware/bluetooth.nix
new file mode 100644
index 00000000..dbff48ec
--- /dev/null
+++ b/system/settings/hardware/bluetooth.nix
@@ -0,0 +1,19 @@
+{ config, pkgs, ... }:
+
+{
+  hardware = {
+    bluetooth = {
+      enable = true;
+      powerOnBoot = false;
+    };
+  };
+  systemd.services.bluetooth.restartIfChanged = false;
+
+  environment.systemPackages = with pkgs; [
+    bluez-tools
+  ];
+
+  services.blueman = {
+    enable = true;
+  };
+}