summary refs log tree commit diff stats
path: root/system/settings/hardware/bluetooth.nix
diff options
context:
space:
mode:
authorAlan Pearce2021-01-12 17:01:45 +0100
committerAlan Pearce2021-01-12 17:01:45 +0100
commit82eac6549fe01ecd4b8aec799f1dba37eb253ecd (patch)
treed452aa54421c1ec547effc951c4f71f3b6f382f1 /system/settings/hardware/bluetooth.nix
parent2ad5213fbb065d59e8435669f71b054bd9fd52f5 (diff)
downloadnixfiles-82eac6549fe01ecd4b8aec799f1dba37eb253ecd.tar.lz
nixfiles-82eac6549fe01ecd4b8aec799f1dba37eb253ecd.tar.zst
nixfiles-82eac6549fe01ecd4b8aec799f1dba37eb253ecd.zip
Extract bluetooth settings from laptop module
Diffstat (limited to 'system/settings/hardware/bluetooth.nix')
-rw-r--r--system/settings/hardware/bluetooth.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/system/settings/hardware/bluetooth.nix b/system/settings/hardware/bluetooth.nix
new file mode 100644
index 00000000..dbff48ec
--- /dev/null
+++ b/system/settings/hardware/bluetooth.nix
@@ -0,0 +1,19 @@
+{ config, pkgs, ... }:
+
+{
+  hardware = {
+    bluetooth = {
+      enable = true;
+      powerOnBoot = false;
+    };
+  };
+  systemd.services.bluetooth.restartIfChanged = false;
+
+  environment.systemPackages = with pkgs; [
+    bluez-tools
+  ];
+
+  services.blueman = {
+    enable = true;
+  };
+}