summary refs log tree commit diff stats
path: root/system/settings/hardware/audio.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/hardware/audio.nix')
-rw-r--r--system/settings/hardware/audio.nix15
1 files changed, 5 insertions, 10 deletions
diff --git a/system/settings/hardware/audio.nix b/system/settings/hardware/audio.nix
index b66f9d04..036fb37d 100644
--- a/system/settings/hardware/audio.nix
+++ b/system/settings/hardware/audio.nix
@@ -1,21 +1,16 @@
 { config, pkgs, ... }:
 
-{ hardware.pulseaudio = {
+{ services.pipewire = {
     enable = true;
-    support32Bit = true;
-    daemon.config = {
-      flat-volumes = "no";
-      avoid-resampling = "yes";
-    };
-    package = if config.hardware.bluetooth.enable
-      then pkgs.pulseaudioFull
-      else pkgs.pulseaudio;
+    audio.enable = true;
+    alsa.enable = true;
+    pulse.enable = true;
   };
 
   sound.enable = true;
 
   environment.systemPackages = with pkgs; [
     pamixer
-    pavucontrol
+    pipecontrol
   ];
 }