summary refs log tree commit diff stats
path: root/system/settings/gaming.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/gaming.nix')
-rw-r--r--system/settings/gaming.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/system/settings/gaming.nix b/system/settings/gaming.nix
new file mode 100644
index 00000000..0dbc5b12
--- /dev/null
+++ b/system/settings/gaming.nix
@@ -0,0 +1,27 @@
+{ config, pkgs, ... }:
+
+{
+  hardware.steam-hardware.enable = true;
+  hardware.opengl.driSupport32Bit = true;
+  hardware.pulseaudio.support32Bit = true;
+
+  systemd = {
+    extraConfig = ''
+      DefaultLimitNOFILE=524288
+    '';
+    user.extraConfig = ''
+      DefaultLimitNOFILE=524288
+    '';
+  };
+
+  networking.firewall = {
+    allowedUDPPorts = [
+      27031
+      27036
+    ];
+    allowedTCPPorts = [
+      27036
+      27037
+    ];
+  };
+}