summary refs log tree commit diff stats
path: root/system/settings/dev.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/dev.nix')
-rw-r--r--system/settings/dev.nix31
1 files changed, 25 insertions, 6 deletions
diff --git a/system/settings/dev.nix b/system/settings/dev.nix
index b1817914..c0937ec0 100644
--- a/system/settings/dev.nix
+++ b/system/settings/dev.nix
@@ -24,18 +24,15 @@
           '';
         };
         # need to test forwarding behaviour
-        "https://alanpearce.localhost" = {
+        "alanpearce.localhost" = {
           logFormat = "output discard";
           serverAliases = [
-            "http://alanpearce.localhost"
-
             # remember to update /etc/hosts
-            "https://alanpearce.test"
-            "http://alanpearce.test"
+            "alanpearce.test"
           ];
           extraConfig = ''
             ${local_tls}
-            reverse_proxy http://alanpearce.test:8080 {
+            reverse_proxy http://alanpearce.localhost:8080 {
               transport http {
                 dial_timeout 1s
                 compression off
@@ -54,6 +51,28 @@
             }
           '';
         };
+        "perplexica-backend.localhost" = {
+          logFormat = "output discard";
+          extraConfig = ''
+            reverse_proxy http://localhost:8339 {
+              transport http {
+                dial_timeout 1s
+                compression off
+              }
+            }
+          '';
+        };
+        "perplexica.localhost" = {
+          logFormat = "output discard";
+          extraConfig = ''
+            reverse_proxy http://localhost:8338 {
+              transport http {
+                dial_timeout 1s
+                compression off
+              }
+            }
+          '';
+        };
       };
   };
 }