summary refs log tree commit diff stats
path: root/system/settings/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/darwin.nix')
-rw-r--r--system/settings/darwin.nix9
1 files changed, 1 insertions, 8 deletions
diff --git a/system/settings/darwin.nix b/system/settings/darwin.nix
index ef039a48..aa55cce5 100644
--- a/system/settings/darwin.nix
+++ b/system/settings/darwin.nix
@@ -4,7 +4,7 @@
 , ...
 }: {
   imports = [
-    ../../pin.nix
+    ./configuration/nix.nix
   ];
   services.nix-daemon = {
     enable = true;
@@ -17,19 +17,12 @@
   ];
 
   nix = {
-    settings.cores = lib.mkDefault 0;
     daemonIOLowPriority = true;
     gc = {
-      automatic = true;
       user = "alan";
       options = "--max-freed $((25 * 1024**3 - 1024 * $(df -P -k /nix/store | tail -n 1 | awk '{ print $4 }')))";
     };
     settings.extra-platforms = "aarch64-darwin x86_64-darwin";
-    settings.experimental-features = "nix-command flakes";
-    settings.warn-dirty = false;
-    settings.keep-outputs = true;
-    settings.keep-derivations = true;
-    settings.use-xdg-base-directories = true;
 
     linux-builder.enable = true;
     settings.trusted-users = [ "@admin" ];