summary refs log tree commit diff stats
path: root/system/settings/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/darwin.nix')
-rw-r--r--system/settings/darwin.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/system/settings/darwin.nix b/system/settings/darwin.nix
index f007fb1d..8fe08a4e 100644
--- a/system/settings/darwin.nix
+++ b/system/settings/darwin.nix
@@ -6,6 +6,13 @@
     enableSocketListener = true;
   };
 
+  programs.zsh = {
+    enable = true;
+    enableCompletion = false; # Causes >2s startup time, overlaps home-manager config
+    enableBashCompletion = true;
+    loginShellInit = builtins.readFile "/System/Library/Templates/Data/private/etc/zprofile";
+  };
+
   environment.systemPackages = with pkgs; [
     watch
     coreutils-prefixed