summary refs log tree commit diff stats
path: root/system/settings/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/darwin.nix')
-rw-r--r--system/settings/darwin.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/system/settings/darwin.nix b/system/settings/darwin.nix
index aa55cce5..6d5b357d 100644
--- a/system/settings/darwin.nix
+++ b/system/settings/darwin.nix
@@ -16,6 +16,7 @@
     [ "/run/current-system/sw" "/nix/var/nix/profiles/default" ]
   ];
 
+  environment.darwinConfig = "$HOME/.config/nixpkgs/darwin-configuration.nix";
   nix = {
     daemonIOLowPriority = true;
     gc = {
@@ -24,7 +25,6 @@
     };
     settings.extra-platforms = "aarch64-darwin x86_64-darwin";
 
-    linux-builder.enable = true;
     settings.trusted-users = [ "@admin" ];
   };
 
@@ -32,7 +32,13 @@
     allowUnfree = true;
   };
 
-  launchd.user.agents.lorri = lib.mkIf config.services.lorri.enable {
+  # needed so that nix-darwin can activate the system as root
+  security.sudo.extraConfig = ''
+    Defaults	env_keep += "NIX_PATH"
+  '';
+
+  services.lorri.enable = true;
+  launchd.user.agents.lorri = {
     serviceConfig = {
       RunAtLoad = lib.mkForce false;
       Sockets = {