summary refs log tree commit diff stats
path: root/system/settings/configuration/nix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/configuration/nix.nix')
-rw-r--r--system/settings/configuration/nix.nix31
1 files changed, 6 insertions, 25 deletions
diff --git a/system/settings/configuration/nix.nix b/system/settings/configuration/nix.nix
index 25b9696f..c8db7836 100644
--- a/system/settings/configuration/nix.nix
+++ b/system/settings/configuration/nix.nix
@@ -8,36 +8,17 @@
   ];
   nix = {
     settings = {
-      cores = 0;
-      auto-optimise-store = true;
+      cores = lib.mkDefault 0;
       use-xdg-base-directories = true;
+      keep-outputs = true;
+      keep-derivations = true;
+      experimental-features = "nix-command flakes";
+      warn-dirty = false;
     };
 
-    daemonCPUSchedPolicy = "idle";
-    daemonIOSchedClass = "idle";
-
-    extraOptions = ''
-      keep-outputs = true
-      keep-derivations = true
-      experimental-features = nix-command flakes
-      warn-dirty = false
-    '';
-
     gc = {
       automatic = lib.mkDefault true;
-      options = "--delete-older-than 14d";
+      options = lib.mkDefault "--delete-older-than 14d";
     };
   };
-
-  system.autoUpgrade = {
-    enable = true;
-    flags = [ "--max-jobs" "2" ];
-    flake = "/home/alan/projects/alanpearce/nixfiles";
-  };
-  systemd.services.nixos-upgrade = {
-    script = pkgs.lib.mkForce ''
-      ${pkgs.nix}/bin/nix-channel --update
-      ${config.system.build.nixos-rebuild}/bin/nixos-rebuild boot --no-build-output ${toString config.system.autoUpgrade.flags}
-    '';
-  };
 }