summary refs log tree commit diff stats
path: root/system/settings/configuration/nix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/configuration/nix.nix')
-rw-r--r--system/settings/configuration/nix.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/system/settings/configuration/nix.nix b/system/settings/configuration/nix.nix
index f4756d58..f152ac27 100644
--- a/system/settings/configuration/nix.nix
+++ b/system/settings/configuration/nix.nix
@@ -1,21 +1,21 @@
 { config, pkgs, ... }:
 
 { nix = {
-    buildCores = 0;
+    settings = {
+      cores = 0;
+      auto-optimise-store = true;
+      trusted-users = [ "@wheel" ];
+    };
 
     daemonCPUSchedPolicy = "idle";
     daemonIOSchedClass = "idle";
 
-    trustedUsers = [ "@wheel" ];
-
-    package = pkgs.nixFlakes;
     extraOptions = ''
       keep-outputs = true
       keep-derivations = true
       experimental-features = nix-command flakes
     '';
 
-    autoOptimiseStore = true;
     gc = {
       automatic = true;
       options = "--delete-older-than 14d";