summary refs log tree commit diff stats
path: root/system/prefect.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/prefect.nix')
-rw-r--r--system/prefect.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/system/prefect.nix b/system/prefect.nix
index 188dfd8f..f9146e8e 100644
--- a/system/prefect.nix
+++ b/system/prefect.nix
@@ -73,6 +73,11 @@
   };
   networking.firewall.allowedTCPPorts = [ config.services.postgresql.port ];
 
+  services.openssh = {
+    enable = true;
+    openFirewall = false;
+    startWhenNeeded = true;
+  };
   networking.firewall.extraCommands = ''
     iptables  -A nixos-fw -p udp --source 172.30.44.0/24       -j nixos-fw-accept
     iptables  -A nixos-fw -p tcp --source 172.30.44.0/24       -j nixos-fw-accept