summary refs log tree commit diff stats
path: root/system/prefect.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/prefect.nix')
-rw-r--r--system/prefect.nix26
1 files changed, 23 insertions, 3 deletions
diff --git a/system/prefect.nix b/system/prefect.nix
index 434c1301..0533e98a 100644
--- a/system/prefect.nix
+++ b/system/prefect.nix
@@ -1,7 +1,6 @@
 { config, pkgs, ... }:
 
 { imports = [
-    ./hardware-configuration.nix
     <nixos-hardware/common/pc/ssd>
     <nixos-hardware/common/cpu/amd>
 
@@ -53,9 +52,28 @@
     zenpower
   ];
 
+  boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "ahci" "usbhid" "sd_mod" ];
+  boot.initrd.kernelModules = [ ];
+  boot.kernelModules = [ "kvm-amd" ];
+
   fileSystems = {
-    "/".options = [ "atgc" "gc_merge" "lazytime" ];
-    "/home".options = [ "atgc" "gc_merge" "lazytime" ];
+    "/" = {
+      device = "/dev/disk/by-uuid/05d67a65-56ad-4c55-98dc-93cec95e34ae";
+      fsType = "f2fs";
+      options = [ "atgc" "gc_merge" "lazytime" ];
+    };
+
+    "/boot" = {
+      device = "/dev/disk/by-uuid/7034-6991";
+      fsType = "vfat";
+    };
+
+    "/home" = {
+      device = "/dev/disk/by-uuid/0128f7e2-8247-435a-bc30-904574d7bf8c";
+      fsType = "f2fs";
+      options = [ "atgc" "gc_merge" "lazytime" ];
+    };
+
     "/mnt/data" = {
       device = "/dev/disk/by-uuid/52E422C5E422AAE5";
       fsType = "ntfs3";
@@ -75,6 +93,8 @@
     };
   };
 
+  swapDevices = [ { label = "swap"; discardPolicy = "once"; } ];
+
   services.xserver = {
     xautolock.enable = pkgs.lib.mkForce false;
   };