summary refs log tree commit diff stats
path: root/system/prefect.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/prefect.nix')
-rw-r--r--system/prefect.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/system/prefect.nix b/system/prefect.nix
index 4d62f94d..565c8084 100644
--- a/system/prefect.nix
+++ b/system/prefect.nix
@@ -101,5 +101,16 @@
     hostName = "prefect";
   };
 
+  services.transmission = {
+    enable = true;
+    openFirewall = true;
+    user = "alan";
+    group = "users";
+    settings = {
+      download-dir = "/mnt/data/Transmission/Storage";
+    };
+  };
+  systemd.services.transmission.requires = [ "mnt-data.mount" ];
+
   system.stateVersion = "22.05";
 }