summary refs log tree commit diff stats
path: root/system/nanopi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/nanopi.nix')
-rwxr-xr-xsystem/nanopi.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/system/nanopi.nix b/system/nanopi.nix
index 7bfe51f0..f750f424 100755
--- a/system/nanopi.nix
+++ b/system/nanopi.nix
@@ -619,12 +619,18 @@ in
     enable = false;
     dates = "04:15";
     randomizedDelaySec = "59 min";
-    channel = "https://nixos.org/channels/nixos-unstable-small";
+    flake = "https://git.alanpearce.eu/nixfiles";
     allowReboot = true;
     rebootWindow = {
       lower = "01:00";
-      upper = "05:00";
+      upper = "06:00";
     };
+    flags = [
+      "--no-write-lock-file"
+      "--override-input"
+      "nixpkgs"
+      "github:NixOS/nixpkgs/nixos-unstable-small"
+    ];
   };
 
   services.miniupnpd = {