summary refs log tree commit diff stats
path: root/system/nano-hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/nano-hardware.nix')
-rw-r--r--system/nano-hardware.nix17
1 files changed, 3 insertions, 14 deletions
diff --git a/system/nano-hardware.nix b/system/nano-hardware.nix
index 96a0a287..ce010ea2 100644
--- a/system/nano-hardware.nix
+++ b/system/nano-hardware.nix
@@ -16,27 +16,16 @@
 
   fileSystems."/" =
     {
-      device = "/dev/disk/by-uuid/3e2e984a-0f2d-4615-be50-cea40090b463";
+      device = "/dev/disk/by-uuid/7c2a0514-b94f-4369-8898-4d038740a2cd";
       fsType = "ext4";
     };
 
   fileSystems."/boot" =
     {
-      device = "/dev/disk/by-uuid/96FE-219D";
+      device = "/dev/disk/by-uuid/EFF6-3E55";
       fsType = "vfat";
-      options = [ "fmask=0022" "dmask=0022" ];
+      options = [ "fmask=0027" "dmask=0027" ];
     };
 
-  swapDevices =
-    [{ device = "/dev/disk/by-uuid/cfedef33-a711-42dd-8816-b1e119e20e55"; }];
-
-  # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
-  # (the default) this is the recommended approach. When using systemd-networkd it's
-  # still possible to use this option, but it's recommended to use it in conjunction
-  # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
-  networking.useDHCP = lib.mkDefault true;
-  # networking.interfaces.eth0.useDHCP = lib.mkDefault true;
-  # networking.interfaces.eth1.useDHCP = lib.mkDefault true;
-
   nixpkgs.hostPlatform = lib.mkDefault "aarch64-linux";
 }