summary refs log tree commit diff stats
path: root/system/modules/services/syncthing.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/services/syncthing.nix')
-rw-r--r--system/modules/services/syncthing.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/system/modules/services/syncthing.nix b/system/modules/services/syncthing.nix
new file mode 100644
index 00000000..b6a12861
--- /dev/null
+++ b/system/modules/services/syncthing.nix
@@ -0,0 +1,11 @@
+{ config, pkgs, ... }:
+
+{ services.syncthing = {
+    enable = true;
+    user = "alan";
+    group = "users";
+    openDefaultPorts = true;
+    systemService = true;
+    dataDir = "/home/alan/.config/syncthing";
+  };
+}