summary refs log tree commit diff stats
path: root/system/modules/satoshipay.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/satoshipay.nix')
-rw-r--r--system/modules/satoshipay.nix71
1 files changed, 0 insertions, 71 deletions
diff --git a/system/modules/satoshipay.nix b/system/modules/satoshipay.nix
deleted file mode 100644
index 9cc5a341..00000000
--- a/system/modules/satoshipay.nix
+++ /dev/null
@@ -1,71 +0,0 @@
-{ config, pkgs, fetchurl, lib, ... }:
-
-{ virtualisation = {
-  docker = let
-    daemonConfig = {
-      ipv6 = true;
-      fixed-cidr-v6 = "fd69:2074:9fcd:b0fd::/64";
-      features = {
-        buildkit = true;
-      };
-    };
-    in {
-      enable = true;
-      enableOnBoot = false;
-      liveRestore = false;
-
-      extraOptions = "--config-file=${pkgs.writeText "daemon.json" (builtins.toJSON daemonConfig)}";
-
-      autoPrune = {
-        enable = true;
-      };
-    };
-  };
-
-  services.mongodb = {
-    enable = true;
-    replSetName = "rs0";
-    dbpath = "/tmp/mongodb";
-  };
-  systemd.services.mongodb.wantedBy = lib.mkForce  [];
-  systemd.timers.mongodb = {
-    description = "Delayed startup of MongoDB";
-    wantedBy = [ "timers.target" ];
-    timerConfig = {
-      OnActiveSec = "1 min";
-    };
-  };
-  systemd.services.mongodb-init = {
-    description = "Init mongodb replicaset";
-    requires = [ "mongodb.service" ];
-    script = "${pkgs.mongodb}/bin/mongo --eval 'rs.initiate()'";
-  };
-  systemd.timers.mongodb-init = {
-    wantedBy = [ "timers.target" ];
-    timerConfig = {
-      OnActiveSec = "2 min";
-    };
-  };
-
-  services.redis = {
-    enable = true;
-  };
-  systemd.services.redis.wantedBy = lib.mkForce [];
-  systemd.timers.redis = {
-    description = "Delayed startup of Redis";
-    wantedBy = [ "timers.target" ];
-    timerConfig = {
-      OnActiveSec = "1 min";
-    };
-  };
-
-
-  services.printing.drivers = with pkgs; [
-  ];
-
-  networking.domain = "satoshipay.io";
-
-  networking.extraHosts = ''
-    127.0.0.1 blogger.local wallet.satoshipay.local api.satoshipay.local ws.satoshipay.local
-  '';
-}