summary refs log tree commit diff stats
path: root/system/modules/programs/gnupg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/programs/gnupg.nix')
-rw-r--r--system/modules/programs/gnupg.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/system/modules/programs/gnupg.nix b/system/modules/programs/gnupg.nix
new file mode 100644
index 00000000..663bcb3c
--- /dev/null
+++ b/system/modules/programs/gnupg.nix
@@ -0,0 +1,10 @@
+{ config, pkgs, lib, ... }:
+
+{
+  environment.systemPackages = with pkgs; [
+    gnupg
+    pinentry
+    (python3.withPackages(ps: with ps; [ trezor_agent wheel ]))
+  ];
+  environment.variables.GNUPGHOME = "$HOME/.gnupg/trezor/";
+}