summary refs log tree commit diff stats
path: root/system/modules/hardware/trackball.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/hardware/trackball.nix')
-rw-r--r--system/modules/hardware/trackball.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/system/modules/hardware/trackball.nix b/system/modules/hardware/trackball.nix
new file mode 100644
index 00000000..9aa5abc0
--- /dev/null
+++ b/system/modules/hardware/trackball.nix
@@ -0,0 +1,13 @@
+{ config, pkgs, ... }:
+
+{ services.xserver.config = ''
+    Section "InputClass"
+        Identifier "Trackball (No Acceleration)"
+        MatchIsPointer "yes"
+        MatchIsTouchpad "no"
+        MatchProduct "Trackball"
+        Option "AccelerationProfile" "-1"
+        Option "AccelerationScheme" "none"
+    EndSection
+  '';
+}