summary refs log tree commit diff stats
path: root/system/modules/hardware/printing.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/hardware/printing.nix')
-rw-r--r--system/modules/hardware/printing.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/system/modules/hardware/printing.nix b/system/modules/hardware/printing.nix
new file mode 100644
index 00000000..96d3a959
--- /dev/null
+++ b/system/modules/hardware/printing.nix
@@ -0,0 +1,19 @@
+{ config, pkgs, lib, ... }:
+
+{ services.printing.enable = true;
+  systemd.services.cups.wantedBy = lib.mkForce [];
+  systemd.sockets.cups.wantedBy = [ "sockets.target" ];
+  systemd.services.cups-browsed.wantedBy = lib.mkForce [];
+
+  systemd.timers.cups-browsed = {
+    description = "Delayed startup of CUPS Remote Printer Discovery";
+    wantedBy = [ "timers.target" ];
+    timerConfig = {
+      OnActiveSec = "2 min";
+    };
+  };
+
+  imports = [
+    ../services/zeroconf.nix
+  ];
+}