summary refs log tree commit diff stats
path: root/system/modules/hardware/network-manager.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/hardware/network-manager.nix')
-rw-r--r--system/modules/hardware/network-manager.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/system/modules/hardware/network-manager.nix b/system/modules/hardware/network-manager.nix
new file mode 100644
index 00000000..f28548a1
--- /dev/null
+++ b/system/modules/hardware/network-manager.nix
@@ -0,0 +1,12 @@
+{ config, pkgs, ... }:
+
+{ networking.networkmanager = {
+    enable = true;
+    dns = "unbound";
+  };
+
+  environment.systemPackages = with pkgs; [
+    networkmanagerapplet
+    networkmanager_dmenu
+  ];
+}