summary refs log tree commit diff stats
path: root/system/modules/hardware/bare-metal.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/hardware/bare-metal.nix')
-rw-r--r--system/modules/hardware/bare-metal.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/system/modules/hardware/bare-metal.nix b/system/modules/hardware/bare-metal.nix
deleted file mode 100644
index 0a61790a..00000000
--- a/system/modules/hardware/bare-metal.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ config, pkgs, ... }:
-
-{ environment.systemPackages = with pkgs; [
-    fuse_exfat
-    cryptsetup
-    dmidecode
-    hdparm
-    pciutils
-    usbutils
-  ];
-
-  hardware.cpu.intel.updateMicrocode = true;
-
-  boot.kernel.sysctl = {
-    "net.ipv4.tcp_allowed_congestion_control" = "illinois reno lp";
-    "net.ipv4.tcp_congestion_control" = "illinois";
-  };
-
-  zramSwap = {
-    enable = true;
-    algorithm = "zstd";
-  };
-  boot.tmpOnTmpfs = true;
-
-  boot.kernelModules = [ "bfq" ];
-
-  fileSystems."/".options = [ "noatime" "nodiratime" ];
-  fileSystems."/home".options = [ "noatime" "nodiratime" ];
-}