summary refs log tree commit diff stats
path: root/system/modules/gaming.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/gaming.nix')
-rw-r--r--system/modules/gaming.nix42
1 files changed, 1 insertions, 41 deletions
diff --git a/system/modules/gaming.nix b/system/modules/gaming.nix
index 44b937a8..0dbc5b12 100644
--- a/system/modules/gaming.nix
+++ b/system/modules/gaming.nix
@@ -1,46 +1,6 @@
 { config, pkgs, ... }:
 
-{ environment.systemPackages = with pkgs; [
-    unstable.steam
-    (
-      unstable.winePackages.unstable.override {
-        pngSupport = true;
-        jpegSupport = true;
-        tiffSupport = true;
-        gettextSupport = true;
-        fontconfigSupport = true;
-        alsaSupport = true;
-        gtkSupport = true;
-        openglSupport = true;
-        tlsSupport = true;
-        gstreamerSupport = true;
-        cupsSupport = true;
-        colorManagementSupport = true;
-        dbusSupport = true;
-        mpg123Support = true;
-        openalSupport = true;
-        openclSupport = true;
-        cairoSupport = true;
-        odbcSupport = true;
-        netapiSupport = true;
-        cursesSupport = true;
-        vaSupport = true;
-        pcapSupport = true;
-        v4lSupport = true;
-        saneSupport = true;
-        gsmSupport = true;
-        gphoto2Support = true;
-        ldapSupport = true;
-        pulseaudioSupport = true;
-        udevSupport = true;
-        xineramaSupport = true;
-        xmlSupport = true;
-        vulkanSupport = true;
-        sdlSupport = true;
-      }
-    )
-    unstable.lutris
-  ];
+{
   hardware.steam-hardware.enable = true;
   hardware.opengl.driSupport32Bit = true;
   hardware.pulseaudio.support32Bit = true;