summary refs log tree commit diff stats
path: root/system/modules/base.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/base.nix')
-rw-r--r--system/modules/base.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/system/modules/base.nix b/system/modules/base.nix
new file mode 100644
index 00000000..9e94a5a2
--- /dev/null
+++ b/system/modules/base.nix
@@ -0,0 +1,13 @@
+{ config, pkgs, ... }:
+
+{ boot.loader.timeout = 1;
+
+  environment.systemPackages = with pkgs; [
+    nix-index
+  ];
+
+  networking.extraHosts = ''
+    127.0.0.1 ${config.networking.hostName}
+    ::1 ${config.networking.hostName}
+  '';
+}