summary refs log tree commit diff stats
path: root/system/mba.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/mba.nix')
-rw-r--r--system/mba.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/system/mba.nix b/system/mba.nix
index 97b5938d..f724dc4f 100644
--- a/system/mba.nix
+++ b/system/mba.nix
@@ -25,6 +25,20 @@
     cores = 4;
     auto-optimise-store = true;
   };
+
+  nix.buildMachines = [
+    {
+      hostName = "lima-nixos";
+      system = "aarch64-linux";
+      sshUser = "nix-remote";
+      sshKey = "/var/root/.ssh/nix-remote";
+      protocol = "ssh-ng";
+      maxJobs = 4;
+      supportedFeatures = [ "nixos-test" "benchmark" "big-parallel" "kvm" ];
+      mandatoryFeatures = [ ];
+    }
+  ];
+  nix.distributedBuilds = true;
 }
 # vim: sw=2 sts=2 expandtab autoindent smarttab