summary refs log tree commit diff stats
path: root/system/marvin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/marvin.nix')
-rw-r--r--system/marvin.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/system/marvin.nix b/system/marvin.nix
index 44c1e9a5..2e88e0d2 100644
--- a/system/marvin.nix
+++ b/system/marvin.nix
@@ -1,8 +1,14 @@
-{ pkgs, ... }: {
+{ pkgs, ... }:
+let
+  srvos = import <srvos>;
+in
+{
   imports = [
     ./settings/darwin.nix
     ./settings/dev.nix
     ./settings/programs/shell.nix
+    <personal/modules/darwin/caddy>
+    srvos.modules.darwin.desktop
   ];
 
   services.caddy = {
@@ -24,6 +30,7 @@
     "/Users/alan/.local/state/nix/profile/bin/fish"
   ];
 
+  environment.darwinConfig = "/etc/nix-darwin/configuration.nix";
   environment.variables.LANG = "en_GB.UTF-8";
 
   launchd.user.envVariables = {