summary refs log tree commit diff stats
path: root/system/marvin.nix
diff options
context:
space:
mode:
authorAlan Pearce2025-03-02 15:18:43 +0100
committerAlan Pearce2025-03-02 23:56:41 +0100
commitb5bcdf72cbc998550bf55af1842fe65f8c9ef0bf (patch)
tree06d7f026a1d6a026aeb548cf7a920a437270d995 /system/marvin.nix
parent734a3cebed8dd4be66a546179dbda890abc5a10d (diff)
downloadnixfiles-b5bcdf72cbc998550bf55af1842fe65f8c9ef0bf.tar.lz
nixfiles-b5bcdf72cbc998550bf55af1842fe65f8c9ef0bf.tar.zst
nixfiles-b5bcdf72cbc998550bf55af1842fe65f8c9ef0bf.zip
Revert "Switch back to flakes"
This reverts commit c0384c43821474d28af1d9696ceb473a0d769292.
Diffstat (limited to 'system/marvin.nix')
-rw-r--r--system/marvin.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/system/marvin.nix b/system/marvin.nix
index 44c1e9a5..2e88e0d2 100644
--- a/system/marvin.nix
+++ b/system/marvin.nix
@@ -1,8 +1,14 @@
-{ pkgs, ... }: {
+{ pkgs, ... }:
+let
+  srvos = import <srvos>;
+in
+{
   imports = [
     ./settings/darwin.nix
     ./settings/dev.nix
     ./settings/programs/shell.nix
+    <personal/modules/darwin/caddy>
+    srvos.modules.darwin.desktop
   ];
 
   services.caddy = {
@@ -24,6 +30,7 @@
     "/Users/alan/.local/state/nix/profile/bin/fish"
   ];
 
+  environment.darwinConfig = "/etc/nix-darwin/configuration.nix";
   environment.variables.LANG = "en_GB.UTF-8";
 
   launchd.user.envVariables = {